2013 Ford EDGE Engine problems & defects.

Rate this post

If you are driving a 2013 Ford EDGE, or if you are planning to purchase one, then it is important that you review reported Engine problems and defects. Total reports: 11.

The Vehicle Hesitates At The Time Of Acceleration And Then Will Surge. The Surging Occurs At Lo Speeds And Is ,unfortunately, Intermittent. A Real Problem In Tight Parking Lots/parking Structures. Almost Hit A Family In A Parking Lot With A Surge Of Speed. The Hesitations Can Occur At Lo Or High Speeds When You Accelerate. I Have Taken It In Several Times And They Say There Is Nothing Wrong. Don’t Know If It Is Transmission Or Accelerator? But It Is Dangerous. *tr

0 person(s) were injured. 0 person(s) died. Mileage was 130 miles. Vehicle Identification Number (VIN):2FMDK3KC5DB. FORD EDGE 2013 problem was reported in SAN MARCOS, CA. Vehicle was not using ANTI-LOCK BRAKES. Vehicle was not using Cruise Control. Vehicle had 6 CYLINDERS. FUEL TYPE: GAS. VEHICLE SPEED: 10 mph.

Aug 09, 2012

2 Weeks After I Bought My edge I Was Attempting To Parallel Park And When My Engine Failure Light Flashed And My Car Just Turned Off. I Have A Push Button Start So I Had To Press The Brake And Attempt To Turn The Car On Again. I Took It To The Dealership And They Told Me They Couldn’t Find Anything Wrong With It. So Again In April And Again A Week Ago Once When I Was Driving On A Normal Street (45 Mph) And While I Was Driving Down The Freeway (75 Mph) My Car Just Turned Off And Stated Engine Failure Low Oil. The 2nd Time It Happened My Car Had 4,000 Miles On It And 5,000 Miles The 3rd Time. I Told The Dealership My Issues And They Told Me They Couldn’t Find The Problem After Having My Car For Just 24 Hours. Your Right, It’s An Intermittent Issue So It’s Not Just Going To Happen While You Took My Car And Drove It 100 Miles. None The Less I Shouldn’t Have To Be Dealing With This In A Vehicle I Paid Over 40k For. The Owner Of Avis ford, [xxx] Told Me It Wasn’t That Big Of A Deal Because It Only Happened 3 Times In 5 Months. My Car Turning Off While Driving Is A Huge Deal And I Could Have Died Any Of Those Times. Engine Failures In A Vehicle That Is Brand New Is A Huge Deal. Information Redacted Pursuant To The Freedom Of Information Act (foia), 5 U.s.c. 552(b)(6). *tr

0 person(s) were injured. 0 person(s) died. Mileage was 323 miles. Vehicle Identification Number (VIN):2FMDK3AK9DB. FORD EDGE 2013 problem was reported in SOUTHFIELD, MI. Vehicle was not using ANTI-LOCK BRAKES. Vehicle was not using Cruise Control. Vehicle had 6 CYLINDERS. FUEL TYPE: GAS. VEHICLE SPEED: 5 mph.

Jan 13, 2013

The 1st Time My Engine Shut Off Was After Making A Right Turn Into A Neighborhood Driving Slowly Looking For An Address. The Second Time Was While Pulling Into My Office Parking Lot; Again At A Slow Speed And The Engine Shut Off. Both Instances Made Steering Impossible. I Took My edge Back To The Dealer For Both Occurrences, However They Claim Only Once!! I Was Told The 1st Time That They Could Find Nothing Wrong With It. This Most Recent Instance They Kept My Car For 2 Days, Drove It Intermittently For 91 Miles And Could Not Reproduce The Problem, Therefore Telling Me Sorry Oh Well, If We Cannot Produce The Problem There Is Nothing To Fix. I Am Outraged And Do Not Know What To Do From Here… *tr

0 person(s) were injured. 0 person(s) died. Mileage was 5721 miles. Vehicle Identification Number (VIN):2FMDK3J95DB. FORD EDGE 2013 problem was reported in PISMO BEACH, CA. Vehicle was not using ANTI-LOCK BRAKES. Vehicle was not using Cruise Control. Vehicle had 4 CYLINDERS. FUEL TYPE: GAS. VEHICLE SPEED: 5 mph.

Aug 01, 2013

My Husband Was Driving Our 2 Months Old Car That Time. Together With Our Kid, We Were Thankful It Happened Just After We Exited The Freeway. As We Stopped On The First Traffic Light Just After The Freeway Exit, We Smelled Something Unusual But Proceeded To The Next Traffic Light And There The Engine Started To Raise Its Rpm Then When He Pumped On The Gas The Car Wont Go Forward And Started To Lower Its Rpm To Almost Zero And Then Died Right On The Traffic Light With 1860 Mileage. He Right Away Switch The Hazard Light But Fortunately No One Is Behind Us. He Turned The Key To Off And Seconds Later Switch It On To Start The Car, It Started Smoothly But Living An Engine Check Light On The Dashboard. We Parked And Called The Dealership, At The Dealership They Said We Refueled It With Wrong Gasoline. This Is Ridiculous, After Two Months Of Filling It! I Don’t Believed Their Conclusion. Could You Please Help Make Action With All This Problem. Im Afraid And Not Confident With This Car. *tr

0 person(s) were injured. 0 person(s) died. Mileage was 1860 miles. Vehicle Identification Number (VIN):2FMDK3GC0DB. FORD EDGE 2013 problem was reported in SAN ANTONIO, TX. Vehicle was not using ANTI-LOCK BRAKES. Vehicle was not using Cruise Control. Vehicle had 6 CYLINDERS. FUEL TYPE: GAS. VEHICLE SPEED: 0 mph.

Aug 17, 2013

I Was Driving On The City Streets And Without Any Warning, The Power Steering Kicked Out. I Didn’t Realize This And Was Already Committed To Making A Left Turn. I Had To Use All My Strength To Make The Turn And Stay On The Road. After Clearing The Intersection I Noticed The Car Was Not Accelerating, Instead It Was Decelerating. The Car Came To A Complete Stop On The Main Road. I Quickly Put On My Blinkers. The Car Then Gave A “low Engine Oil Pressure” Error Message. I Put The Car In Park, Waited A Minute, And Restarted With No Further Issue. I Would Have Had A Big Problem If The Car Stalled Out In The Left Turn Or If I Couldn’t Overpower The Steering Components And Went Off The Road. *tr

0 person(s) were injured. 0 person(s) died. Mileage was 15000 miles. Vehicle Identification Number (VIN):2FMDK3KC1DB. FORD EDGE 2013 problem was reported in PARADISE VALLEY, AZ. Vehicle was not using ANTI-LOCK BRAKES. Vehicle was not using Cruise Control. Vehicle had 6 CYLINDERS. FUEL TYPE: GAS. VEHICLE SPEED: 25 mph.

Sept 04, 2013

Engine Light Went On And Coolant High Temperature Said On The Dashboard. My Wife Was Able To Drive It Home And I Check The Engine Coolant Reservoir And Found It Empty. I Went And Got My Flashlight And Saw Coolant Leak Under The Engine Where The Engine Base Cover Is. I Called The Dealership And Spoke To My Salesman Andrew And He Advised Me To Purchase A Coolant At Autozone And Keep The Receipt And Bring The Car To The Dealer First Thing In The Morning So They Could Have It Check. I Am Just Very Disappointed Due To The Car Has Barely Broken In 744 Mile Only And Just 3 Weeks Old And I Am Getting This Kind Of Problem. I Hope This Is The First And Last Of My Problem With ford. *js

0 person(s) were injured. 0 person(s) died. Mileage was 744 miles. FORD EDGE 2013 problem was reported in CHINO HILLS, CA. Vehicle was not using ANTI-LOCK BRAKES. Vehicle was not using Cruise Control. VEHICLE SPEED: 25 mph.

Sept 25, 2013

I Was Driving To Work 6:30 Am Small Incline And Vehicle Jerked And Stopped ,i Put It Into Park Pushed The Red Ok Button Restarted The Vehicle And Drove Straight To Dealer. They Said It Was The Throttle Body And Fixed It And Changed The Codes The Throttle Was Out Of Range. *tr

0 person(s) were injured. 0 person(s) died. Mileage was 4297 miles. Vehicle Identification Number (VIN):2FMDK3GC4DB. FORD EDGE 2013 problem was reported in LOS ANGELES, CA. Vehicle was not using ANTI-LOCK BRAKES. Vehicle was not using Cruise Control. Vehicle had 6 CYLINDERS. FUEL TYPE: GAS. VEHICLE SPEED: 40 mph.

Jan 22, 2014

The Contact Owns A 2013fordedge. The Contact Stated That While Driving At An Unknown Speed, The Vehicle Stalled Without Warning. The Vehicle Was Not Taken To A Dealer. The Manufacturer Was Not Made Aware Of The Failure. The Failure Mileage Was 31,500 And The Current Mileage Was 32,171.

0 person(s) were injured. 0 person(s) died. Mileage was 31500 miles. Vehicle Identification Number (VIN):2FMDK3GCXDB. FORD EDGE 2013 problem was reported in DALLAS, TX. Vehicle was not using ANTI-LOCK BRAKES. Vehicle was not using Cruise Control.

June 07, 2014

My Wife Was Driving The 2013edge When She Stop In A Left Turn Lane. She Found The Road Was Clear And Stepped On The Gas But The Car Did Not Go Forward. Instead A Warning Message Popped Out Saying The Engine Level Is Too Low. Then She Turned Off The Engine And Restarted The Car. Same Thing Happened And The Car Just Didn’t Accelerate. At Last She Managed To Coast The Car To The Roadside And Called Me For Help. I Arrived In About 20 Mins, Checked The Oil Level And Coolant Temp But Found Nothing Wrong. So I Restarted The Car And This Time It Could Accelerate As Usual. After Getting Home I Contacted The ford Roadside Assist And Had Them Tow The Car To The Nearby Dealer. There They Scanned The Car But All Tests Passed And No Code Had Been Recorded. The Explanation Given By The ford Hotline Is That The Boa(brake Over Accelerator) Feature Reduces Engine Power During Off-idle Driving When The Accelerator And Brake Pedals Are Applied Simultaneously. I Think That Doesn’t Make Any Sense. I Also Tried To Step On Both The Brake And Gas With One Foot But There Is No Way You Can Duplicate The Problem. This Will Be Really Scary If It Happens On The Freeway. I Feel So Frustrated By ford.

0 person(s) were injured. 0 person(s) died. Mileage was 5843 miles. Vehicle Identification Number (VIN):2FMDK3GC7DB. FORD EDGE 2013 problem was reported in HIGH POINT, NC. Vehicle was not using ANTI-LOCK BRAKES. Vehicle was not using Cruise Control. VEHICLE SPEED: 0 mph.

June 19, 2014

About 6 Months Ago While Going Up An Incline The Engine Shut Off At The Top (lost All Power To Brakes And Steering) And The “engine Low Oil Pressure Light Came On”. Turned The Key Off Waited A Minute And Car Started Right Up. Did Not Happen Again Until Yesterday 7/5/14 While Driving (25mph) On Local Street (level) The Same Thing Happened Car Shut Off Without Any Warning Had To Step On Brake Until Car Would Stop (lost All Power To Brakes And Steering) And “engine Low Oil Pressure Light Came On”. Turned Key Off And Waited A Minute And Car Started Right Up. Did Not Bring To Dealership First Time It Happened But Will This Time. Definitely A Safety Concern If This Happeneds On A Highway Going Highway Speeds.

0 person(s) were injured. 0 person(s) died. Mileage was 9000 miles. Vehicle Identification Number (VIN):2FMDK3J96DB. FORD EDGE 2013 problem was reported in GERMANTOWN, MD. Vehicle was not using ANTI-LOCK BRAKES. Vehicle was not using Cruise Control. VEHICLE SPEED: 25 mph.

Jan 11, 2014

Under Hard Acceleration Or Wide Open Throttle The Inside Cabin Of The Vehicle Is Over Come By An Exhaust Like Smell. The Vehicle Has Done This Since It Was New, Thinking It Was From The Engine Breaking In I Never Thought Twice About It. Now After More Than Six Months Of Having The Vehicle And More Than 8,000 Miles, This Is More Than New Car Break In Smell. The Smell Occurs 100% Of The Time Under Hard Acceleration Or Wide Open Throttle, With Or Without The Ac On Or In Ac Recycle Mode. From The Forums That I Have Read, The Owners Of fordedge‘s And ford Explorer’s With The 3.5l V6 Are Experiencing The Exact Same Issue That I Am. The Smell Is Overwhelming To All Passengers That Ride In The Vehicle. The Main Concern Is That The Smell Is Dangerous To Breath In And Second That It’s Very Annoying To Smell All The Time.

0 person(s) were injured. 0 person(s) died. Mileage was 300 miles. Vehicle Identification Number (VIN):2FMDK4JC0DB. FORD EDGE 2013 problem was reported in FAIRFAX, VA. Vehicle was not using ANTI-LOCK BRAKES. Vehicle was not using Cruise Control. VEHICLE SPEED: 60 mph.

Feb 15, 2014

2 Responses

  1. Kathie January 4, 2017 / 7:50 am

    I have a 2014 4 cyl ecoboost Ford Edge SUV that has 23,000 miles on it. About 4 months ago I remember when I was going slow it just stopped. I thought it was odd but when I put it in park it just restarted so kinda brushed it aside. However, yesterday I drove from vista to Rancho Bernardo Sharp Rees Steele office off Via Tazon. Freeway drive ok but pulling into the parking lot, maybe going 8 miles ph the car just stopped. Everything turned off like it was in park with no engine running. The dash had an alert saying low oil pressure. I put it in park and again it started so I parked in a parking place to think (I am kinda old so I needed that). I had another 1000 miles to go before a new oil change and I checked the dip stick three times and it was full. So it didn’t seem to be lacking oil. I was afraid to drive it on the freeway for fear it just stopped again so had a tow truck take us to Vista Ford. They called today to say pick up your car it’s fine. Was low about a 1/4 of a quart of oil and they filled it up. What do u think everyone would u feel comfortable driving on the freeway going 60 if it can just STOP? Any ideas as to what’s wrong or what I should do?

  2. Ramzi Rizvan August 4, 2017 / 1:16 pm

    Ford edge 2013 model. Suddenly in the middle of highway “Low engine oil pressure” and engine cuts off. All electronics keep working including air conditioning. This started happening right after my 90k service. And it is still happening even after ford service centre have investigated the reported issue. And concluded that everything is normal!! It always happen when I’m in a traffic jam and moving very very slowly. The engine shudders when i have applied brakes and then cuts off if i dont start acceleration right away on the symptoms. I then put on hazard lights, move gear to “P”, switch off air conditioning, switch off power, wait few seconds and restart the car. Until then everybody behind me have cursed me and ford. I have had all the issues reported here in this forum! Right from 2nd week of rolling out brand new car from showroom, Al Tayer motors ford agency, UAE. I have extended warranty for the car….not for my life.

Leave a Reply

Your email address will not be published. Required fields are marked *


*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>