Ask a Ford Mechanic

Ask a Ford Mechanic 5.00/5 (100.00%) 1 vote

Get quick answers to your Ford repair questions in the comfort of your home, from verified mechanics experienced in Ford repairs. You don’t need to schedule an appointment with a mechanic and don’t need to wait. Whether you are an enthusiast needing help troubleshooting a Ford or have problems with the repairs, solutions can be a click away. Just ask your Ford question and get an answer ASAP. It’s as simple as that.


12 Responses

  1. Shabbir Takhtawala September 24, 2015 / 4:08 am

    Loud noise from the top front dome above the driver side at speeds beyond 60 mph. Slowing down makes the noise disappear. Ford Taurus SE 2006 sedan.

  2. travis October 1, 2015 / 1:38 am

    i have a 01 f150 5.4 and it shifts only into 2nd but only with high rpms and it also jerks wen it shifts

  3. Karon Smith October 4, 2015 / 3:21 am

    2002 Thunderbird with recurring problem with rough running engine. Have had fuel pump replaced TWICE. Also had Three ignition coils replaced. Have Had car towed three times which included vacation – had to leave two hours from destination and drive rental! — All in two months time –BUT STILL RUNNING ROUGH. Will I be able to get my car fixed? Only 55,000 miles……..feel like car will stop at any moment. Everybody professional BUT CAR IS NOT FIXED.

  4. Kathy October 25, 2015 / 11:30 am

    Have owned 2009 Escape w/59000 actual miles for about a year; no traction when taking off or stopping on slightly wet pavement- possibly tires? Or is it a mechanical issue?
    Traction in snow is very poor. Thank you.

  5. Arthur November 29, 2015 / 6:19 pm

    Driver side control arm broke and punctured my tire yesterday! Did not see it coming. I was side swiped on the driver side and had some external damage to my F150 and it bent my fender,door. Could that have possibly bent my control arm as well without me noticing it,causing it to eventually break?

  6. garnet MacDonald December 9, 2015 / 7:51 pm

    I am buying a 2008 edge 3.5 automatic and I see on some forums a lot of unsafe shifting problems and I don’t see any thing that says ford has fixed this so now i”m thinking I shouldn’t buy it.Can you shed some light on this for me. Thanks Garnet MacDonald

  7. Ron February 20, 2016 / 9:22 pm

    Rubbing noise in front end of car, sounds like a rotor out of true. There is no vibration felt at all in steering. Took my 2014 to the dealership and they couldn’t find the problem. Louder when car is first driven but still there all the time . Dealer said it will either get worse or go away, Duh !

  8. Ron February 20, 2016 / 9:24 pm

    Rubbing noise in front end of car, sounds like a rotor out of true. There is no vibration felt at all in steering. Took my 2014 Ford Escape to the dealership and they couldn’t find the problem. Louder when car is first driven but still there all the time . Dealer said it will either get worse or go away, Duh !

  9. Reid April 9, 2016 / 8:49 pm

    My 1996 ford explorer 4.0 ohv Shuts off randomly. I put a new computer , fuel pump(3), When it does it the pump will not prime. I think it is a short somewhere but I do not know where to look . Thanks

  10. Jimmie June 26, 2016 / 6:32 pm

    I have changed the front brake pad on my 2011 F150. I pressed the caliper pistons in and replaced it over the pads. I can spin the tire and it freely spins. After starting the vehicle and pump up the brakes, I now cannot spin the right wheel. I put the tire on and let the vehicle down to move the vehicle, I now have my rotor rubbing my wheel on the drivers side. Why does this occur. Caliper lines up with bolt holes, Pads are as far forward as possible. Can you help with a solution?

  11. christina rupp January 28, 2017 / 12:03 am

    hooked the code reader up and it came back with no bad codes but the problem is that the car wont go into reverse what is wrong and how do I fix this or what do i do? is it an easy or difficult fix ? I want it done but I want it done right and just need to know what to do and/or what the problem is

    thank you

  12. Tricia April 16, 2017 / 3:21 am

    I have a 2013 Ford Edge. Only purchased it in January of this year. Was due for oil change 3/7/17. My reminder was coming on but no other light. Oil life was at 17%. Tonight it started sputtering and not running right. Engine light is now flashing and my warning sign says change oil soon and is hard to start. Also had a warning that came on that said lower oil pressure. Car shut off when driving.

Leave a Reply to Karon Smith Cancel reply

Your email address will not be published. Required fields are marked *


*

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>